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CNS Barcode

Introduction

When FileMaker, Inc. released their 1.1 version of FileMaker® Go, they added a great
new feature that allows interaction with other iOS apps. The URL scheme they added
allows you to ask FileMaker Go to open a database and run a script. Coupled with the
existing ability to use the Open URL script step to open certain iOS apps via URLs, a
complete back and forth interaction between FileMaker Go and other iOS apps can be
achieved.

CNS Barcode is the first app that achieves this interaction with FileMaker Go, bringing
barcode scanning and creation to FileMaker Go. With both FileMaker Go and CNS
Barcode installed on an iOS Device, you can start in FileMaker Go, invoke CNS
Barcode for scanning a barcode, and then immediately be taken back to FileMaker Go
to process the data from the barcode.

Setting up CNS Barcode to work with FileMaker Go is very easy. The next few pages
will take you step by step through the process.
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Setting up CNS Barcode

There are a couple of different ways you can use CNS Barcode from FileMaker Go, but
the easiest way is to set up a Profile in CNS Barcode. A Profile is a set of preferences
that you give a specific name. When invoking CNS Barcode, you use that Profile Name
to tell the app what preferences should be used.

There are two ways to add a Profile to CNS Barcode: in the app itself, or via the
cnsbarcode://addprofile URL scheme. The first is the easiest, so we will be looking at
that method. The second can be used with the Open URL script step to provide your
users an easy way to add a profile on their device. For more information about the
cnsbarcode://addprofile URL scheme, see the Help tab in CNS Barcode or our
website (http://cnsplug-ins.com/iOS/CNS_Barcode).

Open up CNS Barcode and look at the Settings tab (1). At the bottom of the first
Profiles section is an Add Profile... item (2).

il ATET 2 2:42 PM O 78% d wik ATAT & 3:17 PM @ 9%
Settings Cancel New Profile Dene
Profiles Name Mypeotio 3
Default >
http://www.google.com/m/search?q=::... Launch URL
mydb_single >
fmn'//$/mvdh?scrint=Sinale Scan Ret frp Tsoript/ /S mydd Ap 7 Tscript«Scan_retur.. 4
2 Add Profile... Use :barcode:: 1o indicate where in the
URL %o place the barcode data.
cnsbarcode:// Settings Scanning Options
Default Scanning Profile None > Scan multiple barcodes OFF
Default Generation Profile None Copy barcode to Clpboard OFF

These settings are used when CNS
Barcode is launched by a cnsbarcode:// Save barcode %o Photos OFF

1 T 2 o 3
an Settings 4§

Retum emors OFF

Tap on Add Profile... to open a New Profile screen with several fields. For now, we'll
use the name Myprofile (3). Note that while you can use spaces and other characters
in the name, you will later be using this name in a URL and would have to encode those
spaces and other characters. For more information about URL encoding, see the Help
tab in CNS Barcode or on our website.
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The next setting, Launch URL (4), is the URL that CNS Barcode will launch after you
read a barcode. For now, we'll use the following URL:

fmp://$/mydb?script=Scan_return&param=::barcode::

Note, the URL above will only work with FileMaker Go 12 or higher. If you are using
FileMaker Go 11, you will need to replace “fmp” with “fmp7script”:

fmp7script://$/mydb?script=Scan_return&param=::barcode::

This URL will launch FileMaker Go, asking it to reopen the previously opened “mydb”
database and run a script in that database called Scan_return. The param part tells
FileMaker Go what the Script Parameter should be, which the script can retrieve using
Get( ScriptParameter ). The ::barcode:: part is simply a placeholder for CNS
Barcode to replace with the actual data from the barcode you read. For example, if you
read a barcode that has the value abc123 in it, CNS Barcode will transform the above
Launch URL into this:

fmp://$/mydb?script=Scan_return&param=abcl23

CNS Barcode would then launch this URL, opening FileMaker Go. The Scan_return
script would then use Get( ScriptParameter ) to retrieve the value abc123 and then
act on it.

The remaining Profile settings can be ignored for now. For more information about
them, please see the Help tab in CNS Barcode or our website (http://cnsplug-ins.com/
iIOS/CNS_Barcode).

Don't forget to press the Done button in the top-right corner to save the new Profile.
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Creating a FileMaker Go Database

The next step is to create a database we can use in FileMaker Go. You will need to use
FileMaker Pro on your desktop machine for this part. You also have two choices on
how you can view this database in FileMaker Go. You can either copy the database to
your iOS device via iTunes, or you can simply enable the FileMaker Network Sharing for
the database and open it over the network in FileMaker Go. The second method is very
useful while developing a database for FileMaker Go because any changes you make
show up immediately in FileMaker Go without having to copy the database over via
iTunes again and again.

So, open FileMaker Pro and create a new database named “mydb”. If the “Manage
Database” dialog does not open automatically, go to the File menu -> Manage ->
Database. In the Field Name field, type barcode_data (1), make sure the Type is set
to Text (2), and click the Create button (3).

& Manage Database for “mydd”
| Tables  Fledds « Relationships
P L
Table rycd Y 1 Reld Vew by ¢creston order &
Fwld Narme Type Options / Communts 0k to toggie)
¢ Darcede_data Temn
1 Field Name | Barcode_dama Type Text & — 2
Comment
3 Create Duplicate Delete Copy
Print Cance (oK ) 4

Once you have created the barcode_data field, click OK (4) to close the “Manage
Database” dialog.
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Next, we need to create two scripts, so open “Manage Scripts” by going to the Scripts
menu and clicking “Manage Scripts.” Now click the “New” button (5) in the bottom left
corner to create a new script.

e OO Manage Scripts (mydb)

| Show All s (Q

Name

@Include in menu
5 (P New | v | . Edit § Delete &

In the Script Name field (6) name the script Scan. Next, select the Open URL script
step (7) from the left column and press the “Move” button (8).

e O O Edit Script "New Script” (mydb)*
View: | all by category + | Script Name¢  Scan 6
Open Preferences Open URL [No aialog)

Open File Options

Open Manage Containers
Open Manage Database
Open Manage Data Sources
Open Manage Layouts
Open Manage Scripts
Open Manage Value Lists
Open Find/Replace

Open Help

Open Remote

Open Sharing
Miscellaneous

Show Custom Dialog
Allow Formatting Bar
Beep

Speak

Dial Phone

Install Plug-In File

Install Menu Set

7 Open URL
Perform AppleScript
Execute SQL
Send Event
Comment

Flush Cache to Disk
Exit Application

8 - Duplicate Enable
Show Compatibility

Desktop 4| [ Run script with full access privileges

Script Step Options
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In the right pane, select (9) the Open URL script step, and place a check mark in the
Perform without dialog option box (10). Next, click the “Specify” button (11), a dialog
titted Open URL Options will open and then paste the following into the URL field (12):

cnsbarcode://scan?profile=myprofile

View.  all by category - Script Name: Scan
e Aiaates Wakes | ¢ Open URL [No disiog] 9

Open Manage Value Livta

a) "Open URL™ Op

Open Melp
Open Remote
Open Sharing URL
Miscellaneoun

$how Custom Dialog ensharcode | [scantprofie = myprofie E— 12
Allow Toolban - -

Bees g

Speat _ Cancel ) (0K )

Dval Moo

Iratall Mery Set

«

Open Find Meplace
-
«

et Web Viewar ‘ /
Open URL

Send Mad Scrigt Step Optinns
Perform Appleicripn
Execute SOL

Send Leert

10 ¥ Perform without dalog GE 11

Fleah Cache to Disk
Dot Applcation

Chear Duplicate Ovsable
Show Compatibility

Chent v Run script with full access peivileges

Click OK to close the Open URL Options dialog, and then close the Edit Script
window. When prompted to save the script, do so.

This “Scan” script is the script you call to invoke CNS Barcode for scanning a barcode.
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The second script, named Scan_return, uses a Set Field script step to set the
barcode_data field with the value returned from the CNS Barcode app. When the CNS
Barcode app calls the Scan_return script, it sets the script parameter with the barcode
value. To retrieve the script parameter in the script, we use FileMaker’s

Get( ScriptParameter ) function.

As before, open “Manage Scripts” by going to the Scripts menu and clicking “Manage

Scripts.” Next, click the “New” button (13) in the bottom left corner to create a new
script.

e OO0 Manage Scripts (mydb)

Show All v (Q

Name

Q]Include in menu
13 97 New | v | . Edit elet ¥
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In the Script Name field (14) name the script Scan_return. Next, select the Set Field

script step (15) from the left column and press the “Move” button (16).

15

16

8 00

Edit Script "New Script” (mydb)*

View: | all by category

+ | Script Name: Scan_return

s
Go to Field
Go to Next Field
Go to Previous Field
Enter Browse Mode
Enter Find Mode
Enter Preview Mode

Editing

Undo/Redo

Cut

Copy

Paste

Clear

Set Selection

Select All

Perform Find/Replace

| SetField |
Set Next Serial Value
Insert Text

Insert Calculated Result
Insert from Index

Insert from Last Visited
Insert from URL

Insert Current Date
Insert Current Time
Insert Current User Name
Insert Picture

Insert OuickTime.

Set Field [)

Script Step Options

Show Lompatipility
| Desktop

» Move » Duplicate Enable

4| [_JRun script with full access privileges

14
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In the right pane, select (17) the Set Field script step and click the “Specify target field”

Specify button (18).

8 OO0 Edit Script "New Script” (mydb)*

View: | all by category 4+ | Script Name: [Scan_return

]

Go to Field Set Field () 17

Go to Next Field

Go to Previous Field

Enter Browse Mode

Enter Find Mode

Enter Preview Mode
Editing

Undo/Redo

Cut

Copy

Paste

Clear

Set Selection

Select All

Perform Find /Replace
Fields

Set Field

Set Field By Name

Set Next Serial Value

Insert Text

Insert Calculated Result

Insert from Index

Insert from Last Visited
Insert from URL

Insert Current Date
Insert Current Time
Insert Current User Name
Insert Picture

Insart OuickTime

Script Step Options

| Clear | | Duplicate | | Disable |

Show Compatibility
| Desktop 4| [) Run script with full access privileges

|| Specify target field 1i 8

Calculated result: | Specify... |

In the Specify Field dialog, select the barcode_data field (19), and then click the OK

(20) button.

0.0 6 Specify Field

| mydb +
lbarcodedata B

Repetition:
1 | | Specify... |

[

| Cancel | | oK |

19

20
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With the Set Field script step still selected, click the Calculated result Specify button

(21).

8 OO0 Edit Script "New Script” (mydb)*

View: | all by category + | Script Name: [Scan_return

Go to Field Set Field []

Go to Next Field

Go to Previous Field

Enter Browse Mode

Enter Find Mode

Enter Preview Mode
Editing

Undo/Redo

Cut

Copy

Paste

Clear

Set Selection

Select All

Perform Find /Replace
Fields

Set Field

Set Field By Name

Set Next Serial Value

Insert Text

Insert Calculated Result

]

Insert from Index
Insert from Last Visited
Insert from URL

Script Step Options

Insert Current Date || Specify target field | Specify...

Insert Current Time

Insert Current User Name Calculated result: | Specify... |

Insert Picture
Insert OuickTimea

| Clear | | Duplicate | | Disable |

Show Compatibility
| Desktop 4| [) Run script with full access privileges

21

In the Specify Calculation window, type or copy and paste the following (22), and then

click OK (23).

Get( ScriptParameter )

0.0.0 Specify Calculation

This calculation will be evaluated based on context determined at runtime.

| mydb | Operators ___ View: | all functions by name

barcode_data Abs ( number )

b

/o

Acos ( number)

Asin ( number )

*

g ’
|

*
>

— |< Atan ( number)
> Average ( field {; field...})
=

<
y ’

and Ceiling ( number)
or Char ( number )
xor Choose ( test ; resultO {; resultl ;r...

— Y

Case ( testl ; resultl {; test2 ; resu...

22 | Get( ScriptParameter )

Calculation result must be Text

| Cancel | ( OK

Learn More...

23
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Next, close the Edit Script window and when prompted to save the script, do so.
Finally, close the Manage Scripts window.

This second script is called by CNS Barcode after you have scanned a barcode.

To complete the database, we need to add a button to the layout that Performs the
Scan script and give the button the title Scan.

To create the button, enter Layout mode by going to the View Menu -> Layout Mode.
Next, select the button tool (24), and click and drag with your mouse in an empty
location on your layout (25).

® 00 mydb
35 |- &t (A (TDNEGIO)(E & E Dy (+1%) &) » 24

Layouts Layout Tools

Layout: |'mydb v ¢ Table: mydb ==:v @ A2 Revert Save Layout Exit Layout

barcode_data [Rarcode..data o
25 Scan

B3

&
o

bt

-1
£3

100=9 8 B3 Layout
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In the Button Setup dialog, select the Perform Script step (26) from the list, and then
click the Specify button (27).

0.0.06 Button Setup

In Browse or Find mode, clicking on the selected set of objects will:

Perform Script [<unknown>]
Options

| Do Nothing

Canteal

26 | IEEECEE

Exit Script
Halt Script Current Script:

Set Variable | Pause sl | Specify... | 27
Install OnTimer Script

Navigation
Go to Layout [ Change to hand cursor over button
Go to Record/Request/Page
Go to Related Record
Go to Portal Row
Go to Object
Go to Field
Go to Next Field

Show Compatibility

| Desktop =

Learn More... | Cancel | [ OK | 30

Next, in the Specify Script dialog, select the Scan script (28), and click OK (29), and
then click OK (30) on the Button Setup dialog.

0.0 6 Specify Script

Select a script to perform either in this file or in another
specified file.

| Current File (“mydb.fmp12") 3

[ Show All s (@
| S
o8

< dvan_iewin

+ | = [ g

Optional script parameter:

| [ Edit.. |

[ cancel | [ ok | 29
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Finally, type Scan for the button title (31), and then go to the View Menu -> Browse
Mode, and Save when prompted. The database is now complete and ready to test.

® 00 mydb
. 1
o e AENERIO CEEBWLE) (+) (¢ ,,
Layouts Layout Tools
Layout: "mydb - Vo4 Table: mydb Revert Save Layout Exit Layout
barcode_data Ibamo.dewdata QI
31 Scan
5|
&
o)
bt
-1
3
0= B8 B8 Layout
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Testing

Now that we have a Profile in CNS Barcode and a database to use, all that is left is
testing it to make sure it works. In FileMaker Pro, go to File -> Sharing -> FileMaker
Network. First, enable Network Sharing (1) if it is not already. Next, select the mydb
(2) database, choose the All Users (3) setting, and then click OK (4).

barcade dete

[own |

OO FileMaker Network Settings

FilleMaker Network Settings
Turm on Network Shaning 10 share your apen Nes using TCP/W@

Network Sharing: () Off ® On 1
TCP/IP Addeess: 192.168.0.100; 10.211.55.2;

File access via FileMaker Network

Bl e B
Network access to Sle

2 T | .
® Al users 3

s ey w0 Dy privilege set
(J No users

_ Don't display in Open Remote File dialog

(i) (060 4
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Now, on your iOS Device (iPhone, iPad, etc), open FileMaker Go and tap Open File
Browser...(5). Then tap Local Network Hosts (6) and then the name of your computer
(7). Finally, tap on mydb (8) to open it.

File Browser

Local Hosts ) ! ists  Voyager Pro
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With the database now open, tap the Scan (9) button. CNS Barcode will open, tap the
camera lens (10), and scan a barcode. CNS Barcode will then relaunch FileMaker Go
to call the Scan_return script, which puts the data from the barcode into our field (11).

w.. ATAT T 3:00 PM Q 0% ED il ATAT T 408 PM O B3%Ed
© o CNS Barcode

10

Sevese ae Siod 1 400 0 11

]
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Conclusion

We have seen a very basic example of integrating CNS Barcode with FileMaker Go.
There are many other things you can do with CNS Barcode, including creating barcodes
from data you provide, scanning multiple barcodes, etc. Visit the CNS Barcode website
(http://cnsplug-ins.com/iIOS/CNS_Barcode) for more examples and more information
about the many features of CNS Barcode.
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